Intrepid Ibex, sin sonido?

Sin cuento, la solución es desinstalar el PulseAudio, con cuento, la cosa va asi:

No lo habia notado antes, ya que generalmente trabajo con el sonido apagado, pero el único sonido que escuche a mi equipo desde que instale el Ubuntu 8.10, fue el sonido de arranque, la primera vez que se inició el sistema, y luego de eso nada.

Los diagnósticos de sonido, sólamente dan ruido y no es problema de ajustar el volumen ni nada de eso.

Lugo de googlear un poco, la solución no es para nada complicada, (aunque se trata de un bug no tratado, y esta solución es solo un workaround) y esta ligada a un proceso llamadado pulseaudio y la solución pasa por desinstalar todo lo referido al inche mencionado pulseaudio.

  • Primero nos vamos a Sistema->Administración->Gestor de Paquetes
  • En el panel inferior izquierdo, seleccionamos el botón [Estado]
  • En el panel superior izquierdo, seleccionamos [Instalado]
  • En el cuadro [Busqueda Rápida] escribimos “pulseaudio”, tenemos algo como esto:
Eliminando el PulseAudio

Eliminando el PulseAudio

  • El listado deberia contener sólo los relacionados al PulseAudio, que es lo que queremos eliminar.
  • Con click derecho en cada uno de los botones verdes, los marcamos para eliminar (todos y uno por uno)
  • Le damos al botón verde [Aplicar], que luego de solicitar confirmación aplica los cambios.
  • Si luego de reiniciar, no tenemos sonido nuevamente, debemos seleccionar el dispositivo de sonido:
    • En SIstema->Preferencias->Sonido escogemos el dispositivo de sonido (por default debe estar en autodetectar) talvez debamos ir probando uno a uno.
  • VOILA!!!
Anuncios
    • Simón
    • 24/12/08

    Si fuese tan fácil como lo pintas, no estarían los foros, blogs, listas de correo y webs de reporte de bugs tan llenos de entradas del tipo “Intrepid sin sonido”, etc… Con soluciones de lo más variadas, algunas tan peregrinas como la que aquí publicas…
    De hecho, he acabado en este blog porque ayer se “murió” el sonido y no consigo resucitarlo.
    La solución que tú das, además de ser muy radical, tanto como para dudar de si realmente es una buena idea y de si realmente solucionará algo… También tiene el inconveniente (que no contemplas en tu mini-guía) de que hay paquetes que dependen de pulseaudio como, por ejemplo: avidemux, mjpegtools, virtualbox-2, etc…

    • rafo2001
    • 24/12/08

    Simón, lo que acá pongo es lo que me funciono a mi.
    Una solución radical y oscura pasaría por pedirte que pongas por consola sudo seguido de una serie de comandos y modificadores que ni a bala se entienden.

    Lo que trato de hacer es describir lo que me paso, como lo solucione y por que me parece que paso. A mi me funciono y a varias personas también.

    Lo rescatable de tu comentario es el punto acerca de los paquetes que “dependen” del pulseaudio.
    A mi parecer (no soy un experto ni nada, ya lo aclare de principio) estos se asocian al pulseaudio, como podrían asociarse a cualquier otra fuente de audio, talvez al desinstalar el Pulseaudio se deban desinstalar estos tambien, y al reinstalarlos se asocien a la otra fuente.

    Total estamos aca para aprender no?

    Saludos,

    • Luca
    • 27/02/09

    Gracias, para mi funcionó perfecto.
    Saludos,
    Luca

    • rafo2001
    • 27/02/09

    Gracias a ti,
    Un abrazo.

    • R
    • 28/02/09

    Buenas a tod@s. Que decir que a mi tambien me ha funcionado pero un poco distinto;

    El comando con el que matamos el proceso pulseaudio es:”killall pulseaudio”, pero como lo que nos interesa es matar dicho proceso en cada inicio de sesion, vamos al menu Sistema/Preferencias/Sesiones. En la pestaña “programas de inicio” podemos añadir y quitar de la lista los programas que queremos abrir al inicio de nuestra sesion. Pulsamos el boton “añadir” y donde dice “orden” ponemos el programa a añadir al inicio, en nuestro caso el comando “killall pulseaudio”.
    Cada vez que se abra nuestra sesion, pulse audio sera asesinado.

    A los pocos dias instale en mi intrepid kubuntu y a los dias quise desinstalarlo entero (todas las aplicaciones KDE) pero no pude. Lo que si desinstale fue el paquete kubuntu-desktop, desde entonces no me funciono el audio, cosa que solucione instalando de nuevo el paquete “kubuntu-desktop”.

    Alguien sabe como desinstalar kde entero pero sin quedarme sin sonido?
    Gracias!

    • rafo2001
    • 28/02/09

    Ok, es otra solución.
    Lo que planteabamos era desinstalar el Pulseaudio, tu solución es eliminar el proceso que ya esta corriendo, cada vez que se inicia la sesión.

    Si funciona, bienvenido sea.
    Saludos

    • R
    • 1/03/09

    Buenas a tod@s. Hoy resulta que de nuevo el audio a dejado de funcionar. Ni siquiera se soluciona desinstalando pulseaudio, cosa que me desinstala el paquete ubuntu-desktop. Dicho paquete tengo entendido que es mejor mantenerlo instalado por temas de actualizaciones del sistema (creo). La solucion de desinstalar pulseaudio o la de matar dicho proceso ahora no me han funcionado. Pero seguire probando y buscando. Intrepid no me disgusta, pues me va de maravillas salvo por el audio que me esta mareando, cosa que ademas solo me ocurre en uno de los dos ordenadores, en el otro me va de maravilla el sonido.

    Salud a tod@s!

    • yavirac
    • 17/03/09

    la solucion funciona parcialmente, aqui hay una recomendación que agrega un par de pasos con los cuales solucioné el problema en mi Intrepid sobre una DELL M1210. Realmente el problema que tenia era solo con skype.

    http://www.econowics.com/news-from-the-net/170/skype-problem-with-audio-playback-ubuntu-810-intrepid-ibex/

    • rafo2001
    • 17/03/09

    Resumiendo:
    Matar el proceso “pulseaudio”: ( killall pulseaudio )
    Desinstalarlo : ( sudo apt-get remove pulseaudio )
    Instalar otro gestor de sonido : ( sudo apt-get install esound )
    Eliminar archivos de sesion del pulseaudio : ( sudo rm /etc/X11/Xsession.d/70pulseaudio ) (Esto es nuevo !)
    Reiniciar y voila!

    Es basicamente lo hemos estado diciendo,
    Gracias por el aporte!

    Desins

  1. No trackbacks yet.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: